Rumahweb Journal
setting email wordpress

Memperbaiki Kendala wp-mail-smtp WordPress pada PHP 5.6 keatas

Pada versi PHP 5.6 keatas, pengiriman email SMTP pada WordPress memerlukan SSL yang valid, sehingga jika SSL pada hosting domainnya tidak valid atau belum tervalidasi, maka akan mengalami kendala pengiriman email smtpnya.

Untuk solusi ringkasnya cukup ubah versi php ke PHP maksimal 5.5. Jika ingin tetap menggunakan versi PHP 5.6 keatas, opsinya bisa melakukan perubahan script file WordPress yang digunakan pada file “wp-includes/PHPMailer/PHPMailer.php”  cari baris yang berisi “public $SMTPOptions = [];” dan ubah baris tersebut dengan script berikut :

public $SMTPOptions = array(
'ssl' => array(
'verify_peer' => false,
'verify_peer_name' => false,
'allow_self_signed' => true
)
);

Jika sudah, silahkan simpan perubahan dan coba test kembali pengiriman email WordPress menggunakan SMTP nya.

Selamat mencoba!

Bermanfaatkah Artikel Ini?

Klik bintang 5 untuk rating!

Rating rata-rata 0 / 5. Vote count: 0

Belum ada vote hingga saat ini!

Kami mohon maaf artikel ini kurang berguna untuk Anda!

Mari kita perbaiki artikel ini!

Beri tahu kami bagaimana kami dapat meningkatkan artikel ini?

Tinggalkan Komentar

Afiandhi Risky